Introduction

@nuxtjs/strapi is a Nuxt 3 module for first class integration with Strapi.

This module is a wrapper around Strapi for Nuxt 3.

If you want to use this module for Nuxt 2, check out the documentation of the v0 module: http://strapi-v0.nuxtjs.org/.

Features

  • Nuxt 3 ready
  • Strapi v3 + v4 compatible
  • Authentication support
  • RESTful methods
  • Handle errors with hooks
  • TypeScript support

Strapi v4

This module supports Strapi v3 but also the newest Strapi v4 that came out on November 30, 2021. Check out the announcement: https://strapi.io/v4.